Perlfect Solutions
 

[Perlfect-search] indexing error - 500

Mike Robb perlfect-search@perlfect.com
Sun, 13 Oct 2002 19:12:32 -0700 (Pacific Daylight Time)
Hi-

When I index via HTTP - the first page I try to retrieve is not fetched. The
response error I get is error 500. The page does exist. It responds via web
browsers (http://www.js-x.com/).

The indexing will work if I do it on the server (non HTTP).

Any ideas?

Detailed Output:::::
> perl indexer.pl
LWP::UserAgent::new: ()
Using DB_File...
Checking for old temp files...
Building string of special characters...
Loading 'no index' regular expressions:
        - /home/beaker/public_html/cgi-bin/*
Loading stopwords...371 stopwords loaded.
Starting crawler...
Note: I will not visit more than $HTTP_MAX_PAGES0 pages.
URL LWP::UserAgent::request: ()
LWP::UserAgent::send_request: GET http://www.js-x.com/
LWP::UserAgent::_need_proxy: Not proxied
LWP::Protocol::http::request: ()
LWP::Protocol::http::request: GET / HTTP/1.1
Connection: close
Host: www.js-x.com
User-Agent: Mozilla/5.0
LWP::UserAgent::request: Simple response: (codeP0)Internal Server Error
[Sun Oct 13 18:55:20 2002] indexer.pl: Use of uninitialized value in
substitution (s///) at tools.pl line 44.
[Sun Oct 13 18:55:20 2002] indexer.pl: Use of uninitialized value in regexp
compilation at tools.pl line 45.
[Sun Oct 13 18:55:20 2002] indexer.pl: Use of uninitialized value in regexp
compilation at tools.pl line 45.
Error: Couldn't get 'http://www.js-x.com/': response code 500
Crawler finished: indexed 0 files, 0 terms (0 different terms),
ignored 0 files because of conf/no_index.txt
....


TIA.

-- Mike Robb
http://www.js-x.com/
http://www.sporum.org